Citrix Access Gateway Shows Blank / Black Screen – XenApp

When you log onto Citrix Access Gateway (XenApp), it can just show a blank (black) screen. This is a problem with IE 9 or above. To fix this and get rid of the blank / black screen:

  1. Load into the Citrix Access Gateway website
  2. Press F12
  3. Under Emulation, select the Document mode to be 8, the Browser profile to be Desktop and the User agent string to be Internet Explorer 8

Citrix Access Gateway should now allow you to log in and no longer display a blank / black screen.

VN:F [1.9.22_1171]
Rating: 9.5/10 (17 votes cast)
Citrix Access Gateway Shows Blank / Black Screen - XenApp, 9.5 out of 10 based on 17 ratings

5 thoughts on “Citrix Access Gateway Shows Blank / Black Screen – XenApp

  1. Another way around is to simply click on the gear icon at the top right corner of IE and open the view compatibility menu and add the website to that list.

    VA:F [1.9.22_1171]
    Rating: +5 (from 5 votes)
    • Thanks Adam!

      That’s great news because that means that corporates can stop the Citrix Access Gateway from showing a blank screen for all their users, using a GPO to add the CAG website to compatible sites in IE :mrgreen:

      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
    • Thanks Julien, Citrix had to put out a fix for this sooner or later – IE9 is old now 😛

      VN:F [1.9.22_1171]
      Rating: 0 (from 0 votes)
  2. Agree the funny One that I have this problem with IE 11 and Citrix is suppose to provide the fix to support IE11 with the new version decribe in this CTX : NetScaler Gateway 10.1 – Maintenance Build 120.1316.e

    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)

Leave a comment

Your email address will not be published. Required fields are marked *